Degraded performance - API
Resolved
Feb 12 at 10:04pm IST
The API service experienced degraded performance due to a significant buildup in internal processing queues. The high number of pending requests caused increased response times, which in turn led to elevated 504 Gateway Timeout errors.
The backlog has now been cleared, and API response times have returned to normal levels. We are continuing to monitor the system to ensure stability and to prevent recurrence.
Affected services
Created
Feb 12 at 08:59pm IST
We are currently experiencing degraded performance on our API, resulting in an increased rate of 504 Gateway Timeout responses. This may cause intermittent request failures or delayed responses for some users.
Our engineering team is actively investigating the root cause and working to restore normal service as quickly as possible.
Affected services